TLS requirements made in April 2020 may have negatively impacted your API connection.
In April of 2020, SellerActive implemented a change to require all requests to rest.selleractive.com to use TLS 1.2 in the best interest of our users and in an effort to ensure the security of data and stay up to date with modern encryption, security protocols, and practices. This change was communicated to all customers using our API in advance.
(This does not apply to direct SellerActive to marketplace and partner integrations and just applies for direct rest.selleractive.com API integrations.)
This requirement aligns with industry best practices for security and data integrity as TLS 1.0 and TLS 1.1 are out-of-date protocols that do not support many newer and more secure cryptographic algorithms.
If you are using TLS version 1.0 or 1.1, you will need to upgrade to version 1.2 to ensure requests will function, otherwise, depending on the platform you are using for your integration with our API, you may see an error similar to this:
"The underlying connection was closed: An unexpected error occurred on a send."
- If you use .NET applications, Microsoft recommends .NET 4.7 or later versions.
- If you use PHP, use PHP version 5.6 or higher.
- If you use Java, Java version 8 or higher has default support for TLS 1.2 and Java version 7 has support for TLS 1.2 but is not enabled by default and you must explicitly enable TLS 1.2.
If you are on TLS version 1.2 and receiving an unknown connection error, please reach out to firstname.lastname@example.org for further assistance.